View unanswered posts | View active topics It is currently Mon Mar 25, 2019 10:33 pm



Reply to topic  [ 21 posts ]  Go to page 1, 2  Next
 ABS !?! 
Author Message
Operations Team
User avatar

Joined: Tue May 03, 2005 5:27 pm
Posts: 3072
Location: Oshawa
Reply with quote
Post ABS !?!
Well just got the car out of storage and went to hit the brakes leaving and brakes felt weird and the light came on. Feels like i dont have power brakes as it takes a good bit to get it slowed. Im assuming my ABS took a crap since the light is on? Fluid is fine, not leaking, and or have brake fade feeling. I wasnt really wanting to deal with this but i guess its sooner then later to look at the SJM ABS Delete and Line Lock Kit. :arg:

_________________
1969 Firebird Sprint OHC 6 - 250ci/M5
1995 Trans Am - Blue Green Chameleon - 350ci/A4
1994 Fire-Am - Polo Green - 355ci/M6 380rwhp: SOLD


Sat Mar 31, 2012 1:24 pm
Profile WWW
CCFBG Club Member
User avatar

Joined: Fri Apr 11, 2008 9:57 pm
Posts: 823
Location: scarborough/markham
Reply with quote
Post Re: ABS !?!
The ABS on my Alero was acting up in november. I just pulled the fuse. Hasn't bothered me since.

_________________
1988 Trans Am GTA, LB9, 700R4, CAI, cat back, SFCs, Pro Kit springs, wonderbar, LCRBs


Sat Mar 31, 2012 3:34 pm
Profile
Operations Team
User avatar

Joined: Tue May 03, 2005 5:27 pm
Posts: 3072
Location: Oshawa
Reply with quote
Post Re: ABS !?!
Not so worried about the fact the light is on of my abs doesnt work but just the fact my braking isnt where it should be and takes leaving distance and downshifting to bring it to a stop.

_________________
1969 Firebird Sprint OHC 6 - 250ci/M5
1995 Trans Am - Blue Green Chameleon - 350ci/A4
1994 Fire-Am - Polo Green - 355ci/M6 380rwhp: SOLD


Sat Mar 31, 2012 5:02 pm
Profile WWW
CCFBG Club Member

Joined: Wed Jul 09, 2008 9:16 pm
Posts: 1021
Location: Mississauga
Reply with quote
Post Re: ABS !?!
Sounds like it might be the ABS pump. My dad's STS had the ABS pump go out, brakes felt spongy and stopping distance increased significantly - was actually kinda scary. In his case the light never came on.


Sat Mar 31, 2012 7:39 pm
Profile
CCFBG Club Member
User avatar

Joined: Thu Jul 05, 2007 5:32 am
Posts: 1508
Location: Miserysauga , Ontario
Reply with quote
Post Re: ABS !?!
elimminate it as its not needed

_________________
Image

My FQuick
My Garage

THE MISSISSAUGA CHAPTER


Sat Mar 31, 2012 10:29 pm
Profile
CCFBG Club Member

Joined: Sat Mar 19, 2005 8:15 am
Posts: 3233
Location: Mississauga
Reply with quote
Post Re: ABS !?!
Basic first

Check the vacuum/vacuum line in the booster.


Sun Apr 01, 2012 11:14 am
Profile
Operations Team
User avatar

Joined: Tue May 03, 2005 5:27 pm
Posts: 3072
Location: Oshawa
Reply with quote
Post Re: ABS !?!
Well an update went to check the fluid again since it was fine when i was driving it home. Its now empty a day later. I filled it with fluid but so far i cant see that its leeking. Going to try and bleed the brakes and if that solves it and keep an eye out for leaks.

_________________
1969 Firebird Sprint OHC 6 - 250ci/M5
1995 Trans Am - Blue Green Chameleon - 350ci/A4
1994 Fire-Am - Polo Green - 355ci/M6 380rwhp: SOLD


Sun Apr 01, 2012 7:49 pm
Profile WWW
CCFBG Club Member

Joined: Sat Mar 19, 2005 8:15 am
Posts: 3233
Location: Mississauga
Reply with quote
Post Re: ABS !?!
Which chamber is empty the front or back? If its both it could be the master itself. If its the back it could be the wheel cylinder. Dont bleed it yet. Fill it up and wait for it to leak out.


Sun Apr 01, 2012 10:10 pm
Profile
CCFBG Club Member
User avatar

Joined: Mon Jun 05, 2006 12:38 pm
Posts: 819
Location: Mississauga
Reply with quote
Post Re: ABS !?!
Check you brake booster for any signs of brake fluid - If the master cylinder seal fails it the fluid has been knowm to "disappear" into the booster.

_________________
Image

1978 WS6 W72 TransAm
2008 CTS DD1
2011 Honda CRV DD2
2002 Mazda Miata SE Top Down Fun


Sun Apr 01, 2012 10:14 pm
Profile
Operations Team
User avatar

Joined: Tue May 03, 2005 5:27 pm
Posts: 3072
Location: Oshawa
Reply with quote
Post Re: ABS !?!
Well another two days later fluid is still full and no signs of leaks. Going to wait for my next days off to go out and bleed the system to see if that solves it. Just seems odd as im could of swarn there was some fluid in the resevoir when i first checked and then it was empty and no signs of leaks. Booster appears fine and vacuum line is holding pressure and no leaks.

_________________
1969 Firebird Sprint OHC 6 - 250ci/M5
1995 Trans Am - Blue Green Chameleon - 350ci/A4
1994 Fire-Am - Polo Green - 355ci/M6 380rwhp: SOLD


Wed Apr 04, 2012 10:47 am
Profile WWW
CCFBG Club Member

Joined: Sat Mar 19, 2005 8:15 am
Posts: 3233
Location: Mississauga
Reply with quote
Post Re: ABS !?!
Is it still stiff?


Wed Apr 04, 2012 11:10 am
Profile
Operations Team
User avatar

Joined: Tue May 03, 2005 5:27 pm
Posts: 3072
Location: Oshawa
Reply with quote
Post Re: ABS !?!
Nope its still soft...

_________________
1969 Firebird Sprint OHC 6 - 250ci/M5
1995 Trans Am - Blue Green Chameleon - 350ci/A4
1994 Fire-Am - Polo Green - 355ci/M6 380rwhp: SOLD


Wed Apr 04, 2012 11:29 am
Profile WWW
CCFBG Club Member

Joined: Sat Mar 19, 2005 8:15 am
Posts: 3233
Location: Mississauga
Reply with quote
Post Re: ABS !?!
I suggest to bleed the master first


Wed Apr 04, 2012 12:03 pm
Profile
Operations Team
User avatar

Joined: Tue May 03, 2005 5:27 pm
Posts: 3072
Location: Oshawa
Reply with quote
Post Re: ABS !?!
Took it out for a spin tonight to put some load on it and still no leaks or loss of fluid. Still dont get why if the fluid is full the light hasnt turned off yet?

_________________
1969 Firebird Sprint OHC 6 - 250ci/M5
1995 Trans Am - Blue Green Chameleon - 350ci/A4
1994 Fire-Am - Polo Green - 355ci/M6 380rwhp: SOLD


Thu Apr 05, 2012 7:29 pm
Profile WWW
CCFBG Club Member
User avatar

Joined: Sun Sep 04, 2005 1:11 pm
Posts: 1696
Location: Brampton
Reply with quote
Post Re: ABS !?!
When the passenger side wire burnt for my ABS last winter, brakes felt fine, just didn't have ABS. If your brake feel is different, I would suggest an internal mechanical ABS module fail. This would allow fluid to be moved within the system giving the "spongy" feel while not giving enough brake force.

_________________
Image

1998 Camaro Z/28
2005 Corvette C6 Z51
http://www.fquick.com/slade


Thu Apr 05, 2012 7:48 pm
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 21 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.