View unanswered posts | View active topics It is currently Fri Dec 15, 2017 7:40 pm



Reply to topic  [ 109 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8  Next
 my LT1 build for the SS *updated pics* 
Author Message
CCFBG Club Member
User avatar

Joined: Tue Feb 28, 2006 1:42 pm
Posts: 2740
Location: Mississauga
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
sh8kin wrote:
ok so a little update *no pics yet sorry*
got back from vacation and the car was untouched, kinda of expected from the shop it was at since they are fairly busy with customer car coming in and out all the time. so they got on there horses to finish my car for me this week. i finailly got it back last night and i have put about 200K on it already but man IT GOES LIKE STINK!
the converter is pretty loose feeling inside the city but once i got the car on the highway it was awesome! roller rockers make the engine sound like a sewing machine and the idle has a bit of issues but the lump of the cam is perfect its exactly what i wanted :) i lost a bit of bottom end with the cam i went with but it goes like stink at higher RPM, still a little adjusting, tuning and cleaning i will do it this weekend hopefully then i will have some pics and vids! its going to be a great summer


Roller rockers shouldnt make it sound like a sewing machine. That sound is typical from incorrect length pushrods. SOME valve-train noise should be expected with roller rockers, but not noticeable sewing machine like sounds.

Congratz though! Are you going to be taking this thing to the Tuesday night JCO meets at Meadowvale?

_________________
2012 Camaro 2SS/RS - LS3/TR6060: BTR Cam, Long Tubes, 3" Catback, UDP, CAI Intake, Air Scoop, 3.91 Gears, Poly Diff Bushings, Toe Arms, Poly Subframe, Poly Radius-Rod bushings, ZL1 Suede Shifter, ZL1 Mounts, Arun Tuned - 475rwhp 443rwtq
11.97 @ 116 w/ 1.85 60'

Listen To Song Of My People!
Image


Tue Jun 21, 2011 10:26 am
Profile WWW
Forum User

Joined: Wed Jan 21, 2009 10:19 am
Posts: 173
Location: Toronto
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
its not that its loud like a machine type sound but its alot louder then what the stock stamped rockers are like, its tolerable plus i still have a final adjustment to do, we did do it running mind you but i will try and get them a little quieter.

i may have it out tonight at the JCO meet, trying to get the 1000k mark by the weekend :)

_________________
Image
1995 Impala SS forged 355 LT1, cc503, ported aluminum heads, 1.6RR-7/16, 3200stall, hotchkis suspension- springs/ ext arms/ front end kit, airlift springs, and a big ass heavy stereo all RF
2005 Vibe-wife beater ;)
2006 TBSS (white rocket beater)


Tue Jun 21, 2011 10:32 am
Profile
CCFBG Club Member
User avatar

Joined: Tue Feb 28, 2006 1:42 pm
Posts: 2740
Location: Mississauga
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
sh8kin wrote:
its not that its loud like a machine type sound but its alot louder then what the stock stamped rockers are like, its tolerable plus i still have a final adjustment to do, we did do it running mind you but i will try and get them a little quieter.

i may have it out tonight at the JCO meet, trying to get the 1000k mark by the weekend :)


Sweet. Well im sure you know my Black and gold camaro by now. Its the one that everyone in your JCO club loves to hate on :roll:

Anyways, if youre there and see me come say hi. Id love to see and hear another cammed LT1 8)

_________________
2012 Camaro 2SS/RS - LS3/TR6060: BTR Cam, Long Tubes, 3" Catback, UDP, CAI Intake, Air Scoop, 3.91 Gears, Poly Diff Bushings, Toe Arms, Poly Subframe, Poly Radius-Rod bushings, ZL1 Suede Shifter, ZL1 Mounts, Arun Tuned - 475rwhp 443rwtq
11.97 @ 116 w/ 1.85 60'

Listen To Song Of My People!
Image


Tue Jun 21, 2011 11:09 am
Profile WWW
Forum User

Joined: Wed Jan 21, 2009 10:19 am
Posts: 173
Location: Toronto
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
cool! i will happy to meet another fellow V8 fan ;)

i just really hope the weather holds up tonight i heards it going to be real shitty this week.

_________________
Image
1995 Impala SS forged 355 LT1, cc503, ported aluminum heads, 1.6RR-7/16, 3200stall, hotchkis suspension- springs/ ext arms/ front end kit, airlift springs, and a big ass heavy stereo all RF
2005 Vibe-wife beater ;)
2006 TBSS (white rocket beater)


Tue Jun 21, 2011 11:24 am
Profile
Operations Team
User avatar

Joined: Tue May 03, 2005 5:27 pm
Posts: 3072
Location: Oshawa
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
Congrats i want to see this thing too. Id make the drive but fuel pump is on its last leg and dont to push my luck and it break down and get it towed back to the shwa.

_________________
1969 Firebird Sprint OHC 6 - 250ci/M5
1995 Trans Am - Blue Green Chameleon - 350ci/A4
1994 Fire-Am - Polo Green - 355ci/M6 380rwhp: SOLD


Tue Jun 21, 2011 4:48 pm
Profile WWW
Forum User

Joined: Wed Jan 21, 2009 10:19 am
Posts: 173
Location: Toronto
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
the car drives great only issue i seem to have is with the throttle body and the tuning of the idle. the set screw has adjustment i know this cause i played with it yesterday and bumped the idle so it doesnt stall cold or turning anymore, but now it seems to idle high coming off the highway like the throttle is sticking? right now in park idles at just under 1000rpm and in drive around 800 or so. i also know that the throttle body effects the tranny shifts so they are a little weird too but this is the first time driving with a stall converter so i dont know if its normal or not. i have the IAC relearn but that didnt seem to help, and i have not checked the TPS read out yet i know its supposed to be closed.67 and opened around 4.5 but i have not had the time to look at that yet.

_________________
Image
1995 Impala SS forged 355 LT1, cc503, ported aluminum heads, 1.6RR-7/16, 3200stall, hotchkis suspension- springs/ ext arms/ front end kit, airlift springs, and a big ass heavy stereo all RF
2005 Vibe-wife beater ;)
2006 TBSS (white rocket beater)


Wed Jun 22, 2011 8:14 am
Profile
Senior Forum User

Joined: Fri Apr 13, 2007 1:04 am
Posts: 1116
Location: Mississauga, Ontario
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
sh8kin wrote:
the car drives great only issue i seem to have is with the throttle body and the tuning of the idle. the set screw has adjustment i know this cause i played with it yesterday and bumped the idle so it doesnt stall cold or turning anymore, but now it seems to idle high coming off the highway like the throttle is sticking? right now in park idles at just under 1000rpm and in drive around 800 or so. i also know that the throttle body effects the tranny shifts so they are a little weird too but this is the first time driving with a stall converter so i dont know if its normal or not. i have the IAC relearn but that didnt seem to help, and i have not checked the TPS read out yet i know its supposed to be closed.67 and opened around 4.5 but i have not had the time to look at that yet.


You can barely adjust with that screw. Get it tuned, im sure someone will do it for free. If my laptop still worked i'd say come by and we can see whats going on. Tune!

_________________
1999 Cavalier Z24 Clone 2.2 5MT
1995 Camaro Z28 | SOLD


Wed Jun 22, 2011 1:02 pm
Profile
Forum User

Joined: Wed Jan 21, 2009 10:19 am
Posts: 173
Location: Toronto
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
woot! i got it to idle normally last night after doing a 3 step process i found online, starting with putting the set screw back to just opening the blades, then elongating the TPS holes to make it adjustable and getting the readings near .68 closed and 4.4 at WOT then reseting the IAC and it worked 850RPM @ ilde and 700rpm in drive, im so stoked even with all the load i can give her a/c, stereo turning the wheel she doesnt stall out anymore :) im a happy camper now im going to go back adjust the valves a final time and a synthetic oil change and off to the dyno/drag strip/cruise nights and enjoy the summer :) vid coming tonight

_________________
Image
1995 Impala SS forged 355 LT1, cc503, ported aluminum heads, 1.6RR-7/16, 3200stall, hotchkis suspension- springs/ ext arms/ front end kit, airlift springs, and a big ass heavy stereo all RF
2005 Vibe-wife beater ;)
2006 TBSS (white rocket beater)


Thu Jun 23, 2011 8:35 am
Profile
Operations Team
User avatar

Joined: Tue May 03, 2005 5:27 pm
Posts: 3072
Location: Oshawa
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
Have you had the PCM tuned yet at all? I should be able to find a cc503 a4 tune somewhere on the net to get it in the ball park.

_________________
1969 Firebird Sprint OHC 6 - 250ci/M5
1995 Trans Am - Blue Green Chameleon - 350ci/A4
1994 Fire-Am - Polo Green - 355ci/M6 380rwhp: SOLD


Thu Jun 23, 2011 8:42 am
Profile WWW
Forum User

Joined: Wed Jan 21, 2009 10:19 am
Posts: 173
Location: Toronto
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
I have a mail order tune for the mods i have done he said he would get the idle as close as he can to get it right, i would have to do the final adjustment to get it close. i still might have to see what the iac counts are they should be in the area of high 30's i believe.

_________________
Image
1995 Impala SS forged 355 LT1, cc503, ported aluminum heads, 1.6RR-7/16, 3200stall, hotchkis suspension- springs/ ext arms/ front end kit, airlift springs, and a big ass heavy stereo all RF
2005 Vibe-wife beater ;)
2006 TBSS (white rocket beater)


Thu Jun 23, 2011 8:46 am
Profile
Operations Team
User avatar

Joined: Tue May 03, 2005 5:27 pm
Posts: 3072
Location: Oshawa
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
Ok alteast you have something. You have a fairly common combo so im sure the tune is probubly pretty close. Well if you cant find someone out that way to check you iac counts im out in Oshawa and have laptop with datamaster, tunercats, and cables.

_________________
1969 Firebird Sprint OHC 6 - 250ci/M5
1995 Trans Am - Blue Green Chameleon - 350ci/A4
1994 Fire-Am - Polo Green - 355ci/M6 380rwhp: SOLD


Thu Jun 23, 2011 9:04 am
Profile WWW
Forum User

Joined: Wed Jan 21, 2009 10:19 am
Posts: 173
Location: Toronto
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
cool thanks if i got sometime maybe we will hook up if i cant find anyone else out this way.

_________________
Image
1995 Impala SS forged 355 LT1, cc503, ported aluminum heads, 1.6RR-7/16, 3200stall, hotchkis suspension- springs/ ext arms/ front end kit, airlift springs, and a big ass heavy stereo all RF
2005 Vibe-wife beater ;)
2006 TBSS (white rocket beater)


Thu Jun 23, 2011 9:07 am
Profile
Forum User

Joined: Wed Jan 21, 2009 10:19 am
Posts: 173
Location: Toronto
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
here is my real crappy vid that i got done yesterday sorry its not my best work and the sound was kinda fubar'd at the end for some reason but you get the idea enjoy :)

Image

_________________
Image
1995 Impala SS forged 355 LT1, cc503, ported aluminum heads, 1.6RR-7/16, 3200stall, hotchkis suspension- springs/ ext arms/ front end kit, airlift springs, and a big ass heavy stereo all RF
2005 Vibe-wife beater ;)
2006 TBSS (white rocket beater)


Thu Jun 23, 2011 10:57 pm
Profile
Operations Team
User avatar

Joined: Tue May 03, 2005 5:27 pm
Posts: 3072
Location: Oshawa
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
Whats the idle set at in the video? Really quiet and tame idle... that cc503 normally chops pretty good.

_________________
1969 Firebird Sprint OHC 6 - 250ci/M5
1995 Trans Am - Blue Green Chameleon - 350ci/A4
1994 Fire-Am - Polo Green - 355ci/M6 380rwhp: SOLD


Sun Jun 26, 2011 11:56 am
Profile WWW
Forum User

Joined: Wed Jan 21, 2009 10:19 am
Posts: 173
Location: Toronto
Reply with quote
Post Re: my LT1 build for the SS *updated pics*
in that vid i had it about 900 or so i have got it down to 850 now and about 7 or so in drive or rev. that was just after i got the tps to settle down but it did get back down once the iac reset.

i may have another issue with the guideplates im using after adjusting the valves one last time i notice some of the roller tips are just a bit off-center of the valve tip not much but im worried that they are moving way too much side to side, im using the GM guideplates i dont know it its normal for them to have some side to side movement or should i get back in there and re-adjust the guideplates to get the pushrods to center up better or replace them all together?

_________________
Image
1995 Impala SS forged 355 LT1, cc503, ported aluminum heads, 1.6RR-7/16, 3200stall, hotchkis suspension- springs/ ext arms/ front end kit, airlift springs, and a big ass heavy stereo all RF
2005 Vibe-wife beater ;)
2006 TBSS (white rocket beater)


Mon Jun 27, 2011 8:19 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 109 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.